Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Problem with Joomla and sh404SEF

I just ordered the Starter hosting package, and copied the existing Joomla website there. And it does not work. It shows error: 

Fatal error: Class 'Sh404sefConfiguration' not found in /home/XXXX/public_html/administrator/components/com_sh404sef/sh404seffactory.php on line 139


However, this website works fine at all other hosting providers, including, OVH, 1&1, HostGator... 


I tried changing PHP version to 5.4, 5.6, 7.0, 7.1 - I still face the same error. Google does not find any answers for that. I believe the problem is in the hosting itself. It's a standard Joomla website that should work out of the box. 


Community Manager
Community Manager

Re: Problem with Joomla and sh404SEF

Hi @Maliraata. Welcome to GoDaddy Community! 


It's difficult to say what would be causing the error you're seeing. It seems as though the application is telling you that a class for "Sh404sefConfiguration" hasn't been loaded. I'm not a PHP developer but from what I was able to find online, this could be caused by a number of things. I'd suggest making sure that:

  • All files that are being called are available in their proper locations.
  • You use full PHP tags (<? PHP instead of just <?). 

Hope that helps. If not, feel free to provide more information, including the actual script and domain name. Others in the community may be able to provide you with additional suggestions. 


JesseW - GoDaddy | Community Manager | 24/7 support available at | Remember to choose a solution and give kudos.

Re: Problem with Joomla and sh404SEF

Thank you for a quick reply. It seems that there's a problem with the sf404SEF extension in Joomla. If I turn it off, then everything works fine. It's strange, because it's a popular extension that should work without bugs. It's also strange, that on other machines, it works fine and this error does not appear. I will post new information here, if I will find a solution. Currently I have to use another hosting, because I need this extension enabled.


Re: Problem with Joomla and sh404SEF

I solved this problem.

1) First, I had to get access to Joomla backed. I renamed the sh404sef folder in /administrator/components/ in order to disable the component. After that I could see the Joomla backend login screen

2) After logging in, I renamed the folder back to its original name

3) I reinstalled the component: simply by installing the same version again, without uninstall of the existing version.


After that everything worked fine.


May be this problem happened because I moved the website from one hosting/environment to another. Originally I was using purely nginx, while GoDaddy has Apache. May be sh404sef has an install script which depends on the web server...


I hope my solution will help if someone will face the same problem.