• GoDaddy Community
  • VPS & Dedicated Servers
  • VPS & Dedicated Servers

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 

    Emails sent from VPS to gmail getting bounced "It has been in queue too long, and will not attempt d

    Hi Team,

     

                       When ever i sent email to gmail from domain hosted on my VPS, they are getting bounced. What ever the subject or what ever the gmail account i sent they are getting bounced after 20.6 hours.Verified that my domain or ip are not blacklisted any where. Error message i received is as below.

    This is an automatically generated Delivery Status Notification.
     
    Delivery to the following recipients was aborted after 20.6 hour(s):
     
     
    Reason: There was an error while attempting to deliver your message with [Subject: "REG : Tet email"] to ****************@gmail.com. It has been in queue too long, and will not attempt delivery again.

    I have been verified my delivery logs and they are clear. Event success, Delivery Host: dedrelay.secureserver.net accepted.
    Some one please assist me with this.

    2 REPLIES 2

    Re: Emails sent from VPS to gmail getting bounced "It has been in queue too long, and will not

    I am also experiencing this with some of the emails I am sending to GMail addresses. Any help will be appreciated.

     

    Thanks is advance.

    Re: Emails sent from VPS to gmail getting bounced "It has been in queue too long, and will not

    I struggled with this issue for over two months now. The solution, and the only solution that worked for me, is to add

    1. SPF to your server
    2. DKIM
    3. And [maybe] optional DMARC
     
    If any of the above fails, then emails to gmail will NOT go through.
    You can do a google search on how to add SPF DKIM and DMARC to your server. The following settings worked for me: I use godaddy VPS with email set up. On the back end I use WHM the latest version with Enable DKIM/SPF Globally Enabled under features.
     
    SPF
    1. Login to your CPANEL.
    2. Go to Zone Editor - (under Domains category)
    3. Select your domain and press Manage
    4. Select All under filter. Go through the list checking the Value Column to ensure that NO record starts with v=spf1. If there is such an entry delete it.
    5. Near the top there is an "Add Record" button. Click the arrow next to it and Select Add TXT Record.
    6 Enter the following:
     Name: YourDomainName.com (E.g. example.com)
     TTL: 1400
     Class: IN
     Type: T
     Record: v=spf1 a mx include:secureserver.net -all
     
    7. Save. It will take up to 24 hrs for details to propergate. To test your SPF use the following sites:
     
     
     
     
    DKIM/DMARC
    1. Enable this feature in the WHM features if not enabled already.
    2. Set up global DKIM
    3. Login to the CPANEL 
    4. Click on Authentication (Under Email Category)
    5. Ensure DKIM is Enabled and press UPDATE
     
    6. And this is important as found here:
     
    Go to:
    WHM > Exim Configuration Manager > Advanced Editor 
    Modify the ROUTERSTART section from remote_smtp to dkim_remote_smtp, as follows:
     
    send_to_smart_host:
    driver = manualroute
    route_list = !+local_domains dedrelay.secureserver.net
    transport = dkim_remote_smtp 
     
    Save the Changes.
     
    To test your DKIM Settings, send an email to your Yahoo or any other provider. In Yahoo, open the email and click the three horizontal dots ... at the top of the email. Next click on View Raw Message. Check the raw message for the section dkim=pass (ok)
    If it says OK then it successful. If it says Fail then there is a problem with the DKIM. Check also for SPF to see if it passed.
     
    Note that GMAIL will NOT go through unless SPF and DKIM pass.
     
    Hope this helps.