• GoDaddy Community
  • VPS & Dedicated Servers
  • VPS & Dedicated Servers

    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 

    Email delivery from GoDaddy VPS to Gmail and AOL is delayed and sometimes fail

    I have a VPS from GoDaddy and I use it to send and receive emails.


    The problem is that email delivery to Gmail and AOL is sometimes delayed for several hours and other times it fails completely. I have no problem with email delivery to other email providers.


    Sometimes I get a notification email after about 24 hours from GoDaddy's relay server saying that the email could not be delivered because it stayed in queue for too long. The following is the failure notification email that I get:



    This is an automatically generated Delivery Status Notification.      

    Delivery to the following recipients was aborted after 20.6 hour(s):

      * *****@gmail.com

    Reason: There was an error while attempting to deliver your message with [Subject: "****"] to ******@gmail.com. It has been in queue too long, and will not attempt delivery again.


    Reporting-MTA: dns; p3plsmtps2ded02.prod.phx3.secureserver.net []
    Received-From-MTA: dns; s***-***-***-***.secureserver.net [***.***.***.***]
    Arrival-Date: Mon, 21 Aug 2017 09:37:22 -0700

    Final-recipient: rfc822; ****@gmail.com

    x-originating-ip: ***.***.***.***
    Received: from [] (port=56178 helo=[])
        by s***-***-***-***.secureserver.net with esmtpsa (TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128)
        (Exim 4.89)
        (envelope-from <*****@*****.com>)



    It seems that Gmail and AOL do not trust GoDaddy's email relay server for some reason and delay or reject messages coming from it.


    Also I would like to note that I spoke to a GoDaddy server support rep over the phone and he was not helpful at all. He did not want to look into the problem and kept telling me that I need to figure this out on my own. He was not even aware that emails sent from GoDaddy VPSs have to go through GoDaddy's relay server.


    I will really appreciate if someone from GoDaddy cares enough to help me investigate and resolve this issue.

    3 REPLIES 3
    Helper II

    it is not Godaddy fault... so many people make living using vps and spam emails via VPS.

    If the email is only sent to you you could add the email to your white list or contact ... this way you Electronic Email Service Provider will know to trust that foreign address.


    If it is for others.... I am sure you have seen this in many email... "Please add us to your contact list"

    How can they know what to add in their contact list if they are not getting the emails?

    I struggled with this issue for over two months now. The solution, and the only solution that worked for me, is to add

    1. SPF to your server
    2. DKIM
    3. And [maybe] optional DMARC
    If any of the above fails, then emails to gmail will NOT go through.
    You can do a google search on how to add SPF DKIM and DMARC to your server. The following settings worked for me: I use godaddy VPS with email set up. On the back end I use WHM the latest version with Enable DKIM/SPF Globally Enabled under features.
    1. Login to your CPANEL.
    2. Go to Zone Editor - (under Domains category)
    3. Select your domain and press Manage
    4. Select All under filter. Go through the list checking the Value Column to ensure that NO record starts with v=spf1. If there is such an entry delete it.
    5. Near the top there is an "Add Record" button. Click the arrow next to it and Select Add TXT Record.
    6 Enter the following:
     Name: YourDomainName.com (E.g. example.com)
     TTL: 1400
     Class: IN
     Type: T
     Record: v=spf1 a mx include:secureserver.net -all
    7. Save. It will take up to 24 hrs for details to propergate. To test your SPF use the following sites:
    1. Enable this feature in the WHM features if not enabled already.
    2. Set up global DKIM
    3. Login to the CPANEL 
    4. Click on Authentication (Under Email Category)
    5. Ensure DKIM is Enabled and press UPDATE
    6. And this is important as found here:
    Go to:
    WHM > Exim Configuration Manager > Advanced Editor 
    Modify the ROUTERSTART section from remote_smtp to dkim_remote_smtp, as follows:
    driver = manualroute
    route_list = !+local_domains dedrelay.secureserver.net
    transport = dkim_remote_smtp 
    Save the Changes.
    To test your DKIM Settings, send an email to your Yahoo or any other provider. In Yahoo, open the email and click the three horizontal dots ... at the top of the email. Next click on View Raw Message. Check the raw message for the section dkim=pass (ok)
    If it says OK then it successful. If it says Fail then there is a problem with the DKIM. Check also for SPF to see if it passed.
    Note that GMAIL will NOT go through unless SPF and DKIM pass.
    Hope this helps.