cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Highlighted

Wordpress site stopped working

I am a novice at wordpress and don't know how to fix these PhP errors. I think the Fatal error at the bottom is the main issue. Help would be greatly appreciated!

 

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Translation_Entry has a deprecated constructor in /home/canvaas/public_html/wp-includes/pomo/entry.php on line 14

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; POMO_Reader has a deprecated constructor in /home/canvaas/public_html/wp-includes/pomo/streams.php on line 12

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; POMO_FileReader has a deprecated constructor in /home/canvaas/public_html/wp-includes/pomo/streams.php on line 120

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; POMO_StringReader has a deprecated constructor in /home/canvaas/public_html/wp-includes/pomo/streams.php on line 175

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; POMO_CachedFileReader has a deprecated constructor in /home/canvaas/public_html/wp-includes/pomo/streams.php on line 221

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; POMO_CachedIntFileReader has a deprecated constructor in /home/canvaas/public_html/wp-includes/pomo/streams.php on line 236

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; WP_Widget_Factory has a deprecated constructor in /home/canvaas/public_html/wp-includes/widgets.php on line 544

Warning: require_once(/home/canvaas/public_html/wp-content/themes/ken/framework/php/ReduxCore/framework.php): failed to open stream: No such file or directory in /home/canvaas/public_html/wp-content/themes/ken/functions.php on line 162

Fatal error: require_once(): Failed opening required '/home/canvaas/public_html/wp-content/themes/ken/framework/php/ReduxCore/framework.php' (include_path='.:/opt/alt/php71/usr/share/pear') in /home/canvaas/public_html/wp-content/themes/ken/functions.php on line 162

1 REPLY 1
Super User II Super User II
Super User II
Solution

Re: Wordpress site stopped working

@Lebronshades

 

"Depreciated" indicates that something isn't up to the latest and greatest. 

 

You want to be on PHP 7.X.   WordPress recommends 7.2

 

If you are using plugins or a theme that require PHP 7 but you are on PHP 5.6 you may have issues.  At the same time older plugins or themes may not be PHP 7 compatible.  Here's a plugin to check your version and compatibility!

 

HTH! 🙂

 

Judith
"Many of life's failures are people who did not realize how close they were to success when they gave up." ~Thomas Edison