cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Highlighted

Email forwarding through Workspace email not working

After some searching, I just found out how to switch back to the "old" account panel design and start setting up Workspace Email/ email forwarding with Gmail.

 

I created info@mydomain.co as a user, set it as a "catch-all" address and forwarded it to username@gmail.com. I sent a few test emails from mygmail@gmail.com to something@mydomain.com and info@mydomain.co. The emails did not bounce, but they also didn't arrive. I then tried sending a test from mygmail@gmail.com to username@gmail.com just to be sure Gmail wasn't the issue and the message immediately came through.

 

Any ideas what to do?

10 REPLIES 10
Helper I
Helper I

Re: Email forwarding through Workspace email not working

Hey, @nilsdecker,

 

I've used Email forwarding a lot, and I've not had any issues.  It can take a few minutes for the GoDaddy backend to process the forwarding setup.  After you've waited a few minutes... is it still not working?

 

FYI, I've been using the "old" panel since the time it was THE only panel.  Tried a cPanel setup once... it's not bad -- but not what I'm familiar with.

 

Ray

Not a GoDaddy employee or support staff; I am a GoDaddy Pro with significant experience using a variety of GoDaddy services.
Solution

Re: Email forwarding through Workspace email not working

Thanks @RayHAz

 

The missing piece of the puzzle was that I had not yet set up MX-records. Which I just did and it is working now.

Re: Email forwarding through Workspace email not working

I am having a similar issue (but maybe in reverse). We set up "admin@mydomain.com" and then converted it to my employee's name: "name@mydoamin.com."  We would like to get rid of "admin@mydomain.com" now, but we can't seem to. We are finding it confusing for her (and our clients) to have two accounts. There is no longer a listing in Office 365 for the "admin" account, only the employee's name.

Re: Email forwarding through Workspace email not working

Hi, can you elaborate more on what you did to solve the problem? I'm at the same stage but can't figure out which MX-records to change or where. Thanks!

Re: Email forwarding through Workspace email not working

Yeah me too. I posted this same question weeks ago and haven't got an answer. I don't know how to change the MX settings or what to change them to to get them to work for my gmail forward.

Re: Email forwarding through Workspace email not working

I struggled with this issue for over two months now. The solution, and the only solution that worked for me, is to add

1. SPF to your server
2. DKIM
3. And [maybe] optional DMARC
 
If any of the above fails, then emails to gmail will NOT go through.
You can do a google search on how to add SPF DKIM and DMARC to your server. The following settings worked for me: I use godaddy VPS with email set up. On the back end I use WHM the latest version with Enable DKIM/SPF Globally Enabled under features.
 
SPF
1. Login to your CPANEL.
2. Go to Zone Editor - (under Domains category)
3. Select your domain and press Manage
4. Select All under filter. Go through the list checking the Value Column to ensure that NO record starts with v=spf1. If there is such an entry delete it.
5. Near the top there is an "Add Record" button. Click the arrow next to it and Select Add TXT Record.
6 Enter the following:
 Name: YourDomainName.com (E.g. example.com)
 TTL: 1400
 Class: IN
 Type: T
 Record: v=spf1 a mx include:secureserver.net -all
 
7. Save. It will take up to 24 hrs for details to propergate. To test your SPF use the following sites:
 
 
 
 
DKIM/DMARC
1. Enable this feature in the WHM features if not enabled already.
2. Set up global DKIM
3. Login to the CPANEL 
4. Click on Authentication (Under Email Category)
5. Ensure DKIM is Enabled and press UPDATE
 
6. And this is important as found here:
 
Go to:
WHM > Exim Configuration Manager > Advanced Editor 
Modify the ROUTERSTART section from remote_smtp to dkim_remote_smtp, as follows:
 
send_to_smart_host:
driver = manualroute
route_list = !+local_domains dedrelay.secureserver.net
transport = dkim_remote_smtp 
 
Save the Changes.
 
To test your DKIM Settings, send an email to your Yahoo or any other provider. In Yahoo, open the email and click the three horizontal dots ... at the top of the email. Next click on View Raw Message. Check the raw message for the section dkim=pass (ok)
If it says OK then it successful. If it says Fail then there is a problem with the DKIM. Check also for SPF to see if it passed.
 
Note that GMAIL will NOT go through unless SPF and DKIM pass.
 
Hope this helps.
Solution

Re: Email forwarding through Workspace email not working

I ended up switching over to safteynames__dot__com - they offer professional email for $1 and it's much easier to set up than this hack. You can simply create a forwarder with them to your gmail inbox and then add the account of your personal domain as an alias. Support is great too. 

Re: Email forwarding through Workspace email not working

Hi, In case I want to forward email to a gmail account, I have the same issue, it doesnt bounce but also doesnt arrive? In case I have to add anything, can anyone assist in what I need to do?

Re: Email forwarding through Workspace email not working

I just recommend you pay for gsuite or find another provider that can support that setup (see my previous response). The hassle of getting it to work with the chances of breaking it are too high. Check out safetynames.com and see if they can help you out.

Re: Email forwarding through Workspace email not working

I had the same issue trying to forward mail from info@mydomain.com to another email hosted on gmail, and I solved it by setting the MX records on mydomain DNS settings.

 

How to do this:

 

After you have setup Email Forwarding, go to the My Domains page on the Godaddy website.

 

In the My Domains page, locate your domain name (e.g. mydomain.com) in the list of domains and click on the 3 dots next to the domain name. Select the Manage DNS option. This will take you to the DNS Management page for your domain (You can also access the DNS Management page through the Domain Settings page and click on the Manage DNS link at the bottom of the page).

 

On the DNS Management page you will see a list of different Records.  Click the ADD button at the bottom of the Records section.

 

A dialogue window will open, and the Type field will display. select MX from the Type dropdown list. This will display more fields to complete.

 

Add the following record:

 

For the Type field:             MX

For the Host field:             @

For the Points To field:     mailstore1.secureserver.net

For the Priority field:        10

For the TTL field:              1 hour

 

Then click save. And the dialogue window will close

 

Add another record by clicking the ADD button again.

 

Add the following:

 

For the Type field:                MX

For the Host field:                @

For the Points to field:         smtp.secureserver.net

For the Priority field:            0

TTL:                                       1 hour

 

Click save and the dialogue window will close.

 

Give it a few minutes ,and then send an email to your new domain email address(e.g. info@mydomain.com) from another email address (not the email address you are expecting to receive the forwarded messages), and you should now see that the message you sent is forwarded to the email address you wanted to receive the forwarded messages.

 

Hope this helps someone 🙂