cancel
Showing results for 
Search instead for 
Did you mean: 

SPF Record not working? What am i doing wrong?

Hello!

I'm trying to set up SPF with Migadu and the Godaddy DNS Manager.

 

Either way, Instructions Say: 

https://photos.app.goo.gl/djQSWTrRm72EP8ui2

 

So, I have set it up, by method of copy-paste.

https://photos.app.goo.gl/4DL68rHpM8eZQzsI2

 

Which has resulted in this:

https://photos.app.goo.gl/376sNfpxHCuMlBVf1

 

So, The question is, What have i done to get a result that's "Not Valid"

and what do i need to do to fix it?

(Please dumb it down to idiot-level-instructions, as I'm not good at this)

 

:::EDIT:::

I've tried THREE TIMES to upload images directly into the post, each time, they appear in preview, but don't work once posted. So have some links to the images instead.

3 REPLIES 3

Re: SPF Record not working? What am i doing wrong?

Hi,

do you have a solution for your problem?

I have the same problem and I can´t get it to work

Community Manager
Community Manager

Re: SPF Record not working? What am i doing wrong?

Hi @techdiffuse - I'm not sure if @DazzaJay was able to sort this out, but in their situation, it looks like the issue is due to the copying and pasting the value. When I look up the domain from the screenshot in a dig, the record appears to end with ?all instead of ~all. If you'd like to share your domain, I'd be happy to take a look at it and see if there are any obvious problems with your SPF record.

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

Re: SPF Record not working? What am i doing wrong?

Hi @JesseW ,

 

thanks for answering me.

I copy pasted the value from the migadu Website and I also tested some variations but now it is working with the original setup: 

TXT@v=spf1 a mx include:spf.migadu.com ~all

Maybe it just took a bit longer to get it working correctly for this specific record. First, I was confused, cause all the other values for MX, default._domainkey and _dmarc were almost instantly accepted from their verification tool except the spf value. I contacted their support team, but as soon as the answered (about an our later or so) it worked without any modifications.

 

Best Regards

Michael