cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Hosting a Wordpresss multisite network with own domains

Hi,

I plan to setup a network of websites using Wordpress multisite, it seems OK on Godaddy seeing this.

Since I will have to use the directory structure, I wonder if each sites in the network can have its own domain name.

Let's imagine we have a network a.com and sites a.com/site1 & a.com/site2, would it be possible to have site.com & site2.com domain names showing the correct website on the network? I'm not sure since these are not real directories.

Thanks

3 REPLIES 3
Community Manager
Community Manager
Solution

Re: Hosting a Wordpresss multisite network with own domains

Hi, @Junelsa. Thanks for being part of GoDaddy Community! You wouldn't be able to use two domains on a multisite WordPress network without making modifications to your install. I have seen at least one plugin that offers to help you do this, so that might be something you could look into. If you figure it out, it would be great if you could update here regarding what you did. Others might benefit from your experience. 

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

Re: Hosting a Wordpresss multisite network with own domains

Hi @JesseW,


Thanks for the answer. It seems to be native now seeing here. 🙂 THis should work on Godaddy I guess.

 

Note: By "this" in my message above, I was referring to: https://www.godaddy.com/help/enabling-wordpress-multisites-6143 (forgot the link :))

 

Re: Hosting a Wordpresss multisite network with own domains

Hi Junelsa,

Were you able to get site1.com and site2.com to work for your multisite setup? I'm trying to do the same thing and I can't get site1.com and site2.com to show in the address bar instead of network/site1 and network/site2. I think I made all the correct changes in WordPress. Maybe there is something in GoDaddy domain set up that I didn't do? If you were able to get it to work, what did you do? Thanks.