Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

FTP No Longer Connecting After Password Change

We recently updated our FTP password, and we can no longer connect via FTP.  The product we use is Ultimate Web Hosting Linux, NOT THE NEWER VERSION.  We logged into the Hosting control panel on GoDaddy's website, selected "FTP Users" and "Change Password".  We were extremely careful and triple checked the password.
When we type the new password into FileZilla (which is what we've used for years & years), we can no longer access our server.  We tried the old password too, but it doesn't work either.
What can we do?

Re: FTP No Longer Connecting After Password Change

Update: That was a frustrating day.  My wife & I spoke with customer service on the phone.  They told us the FTP Username/Password were "being updated but are backed up" and that it "may take around 3 hours" to work properly.  I ended up waiting 14+ hours and the FTP username edit page still says "Pending Update".  Eventually I created a new username & password which began working in about 30 seconds.


Something is broken on GoDaddy's side, but at least the new username & password work-around "fixed it" well enough that I can use my server.  I hope this helps someone who searches for this problem one day!  🙂

Re: FTP No Longer Connecting After Password Change

Also note that there appears to be an additional 'secret' security requirement for passwords which is not listed as a requirement: the password cannot contain more than 2 repeated characters next to each other.


I had repeat numbers (111) as part of a sequence, and on a retry I had repeat exclamation points (!!!), both of which the godaddy password reset accepted as valid, but which failed when actually using them in FTP.


Changing the password to remove repeated values allowed FTP to accept the credentials and work normally.


Allowing repeated characters increases the variety of possible passwords, but it also encourages people to use easily-guessed passwords like 'a1111111'. 


Not sure if this is actually a thing, but it's worth trying if you've changed your password and it has 3+ of the same characters next to each other. Worked for me.