Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Cannot SSH

I've created an FTP account through cPanel > Files > FTP Accounts.  I've also attempted to enable SSH access through cPanel > Security > SSH access, however the SSH access always has the option to 'enable' when I go back into that menu area so I'm not sure it is sticking.


I can use Filezilla to FTP with the encryption set to 'Use explicit FTP over TLS if available' but I cannot use the SFTP protocol because I get an error "Authentication Failed. Critical Error. Could not connect to server'.


I also cannot use terminal (on a mac) to SSH via the command line.  I keep getting the error 'Permission denied, please try again.'


I need to be able to SSH through terminal as well as SFTP.  What can be done to get this working?


Helper IV
Helper IV

Re: Cannot SSH

To log in through FTP (FileZilla).  You should know the primary credentials of your web hosting.  Follow the video tutorial below.

SSH Access.


Thank You.


Re: Cannot SSH

I don't need to use FTP, I need to use SSH with Terminal on a Mac OS X.  This should be doable according to this:


I've set up the account, but when log in, I get a permission denied using terminal on mac



where username is my username and ipaddress is my website ip address as listed in cpanel


I type in the password at the prompt but get 'Permission denied, please try again'




Helper IV
Helper IV

Re: Cannot SSH

Re: Cannot SSH

Hi, I also have the same problem. I hope someone could help.


Re: Cannot SSH

I know how to ssh on mac.  However I get a permission denied when I log in.  So, even though I have an account, and I know how to ssh, the server denies access to me.

SSH asscess for root

When I am using a normal user name with password , I am able to login in my vps IP. But when I am using root as user by using the same password it is saying access denied. What is the password for the root user

Re: Cannot SSH

it doesn't work for me either. i know how to SSH, i've ssh'd into dozens of computers and servers, but this one is a no-go

Re: Cannot SSH

SSH it show me anable but my ftp user cannot use the ssh 

WTF guys are you going to fix it or not?

Re: Cannot SSH

Well i have the solution

ONLy primary ftp user have access to ssh


Re: Cannot SSH

@gagathok Thanks! We were banging our heads and GoDaddy support wasn't a help. You gave us the hint! It is indeed the case tha tonly primary ftp user has access to SSH. Hope it help others too. Thanks again!


Re: Cannot SSH

To connect to server through SSH, you need to use Primary Domain FTP credentials.


To check Primary domain FTP details -> go to Hosting -> FTP Users -> search for user have access to primary domain.


You can access SSH only using FTP user who have access to primary domain, were all other user have only FTP access.

Re: SSH asscess for root

From what I've seen they don't allow the actual "root" user. There is a primary user that must be used. Then you can sudo su or whatever to switch to "root" if you need to. Just my experience. So try using your primary user with the root password/key.




How can I connect my hosting with SSH. I've enabled this option using cpanel and using my ftp credentials for it. Is it the correct way? If not then please guide me. Thanks

Re: Cannot SSH

I had the problem of not being able to connect via SFTP and was getting very frustrated because it meant I could not use putty. This problem arose after I reset my hosting account so I could start a new website using a fresh hosting setup.


I could FTP but not SFTP. Tech support kept saying it must be something on my end as far as my connection. 


However, eventually I simply reset the account again, which was not a problem because I was starting a new website. (Not so simple if you already have a website in place!) During this reset process, I was very careful not to do anything involving SSH except to press the "enable" button and leave it at that. I did not do anything further involving managing the key. I did not press any more SSH buttons. I left all that alone. I also did not set up any new FTP accounts. (There are already two special FTP accounts set up by default).


Then when I used WinSCP to SFTP, it worked, although it did warn me about the unknown key and asked me to verify it was OK, which I did. That was just a one-time process.


In other words, the whole problem (for me) involved the setup of SSH in Cpanel during the reset process, nothing at all to do with my internet connection. 


Of course YMMV, so good luck! 

Re: Cannot SSH

Okay so, I just had the same issue and wanted to share what worked for me. I am familiar with SSH access, keys, commands, etc. I'm not exactly a tech numb-numb. This is, however, the first time I've worked with GoDaddy anything (my other clients are with my hosting platform on separate servers).


I spend about 15-20 minutes setting up Git, SSH keys and Agent stuff, setting up FTP, the whole deal. Whatever. I go to test my SSH access. Denied. Crap.


Denied... Denied... Denied... I hit the Google. Find this. @rohankhude's suggestion of the root FTP account worked. This username can also be found under your "My Hosting" screen in a box in the bottom right under "Settings" called "cPanel Login". It'll probably look like someone mashed the keyboard, e.g: uiygasdkjhgbwaebl


GoDaddy support, by the way: WOW you guys are awful. If I encountered that kind of response from you guys I would pick up my digital skirts and run for the hills, domains and all. You might as well have given the standard troll response: "Google it".

Re: Cannot SSH

Just so you know....

For Cpanel Linux account:

host is your IP address

user name: listed bottom right of your CPanel Account (not your billing account user)

password:  I reset mine 3 times


I finally chatted with customer services.  (not terribly useful)


I remembered back to ancient tech days when I would telnet (similar to SSH).


Back then you couldn't backspace to make a correction.  So I typed everything very slowly and

don't you know... I got in....


I'm going to go google and see if this really is an issue with SSH...  Found an article pretty quickly verifying issue.